Add Debian package.
[util-vserver.git] / debian / rules
diff --git a/debian/rules b/debian/rules
new file mode 100755 (executable)
index 0000000..3124d86
--- /dev/null
@@ -0,0 +1,31 @@
+#!/usr/bin/make -f
+# -*- makefile -*-
+# Sample debian/rules that uses debhelper.
+#
+# This file was originally written by Joey Hess and Craig Small.
+# As a special exception, when this file is copied by dh-make into a
+# dh-make output file, you may use that output file without restriction.
+# This special exception was added by Craig Small in version 0.37 of dh-make.
+#
+# Modified to make a template file for a multi-binary package with separated
+# build-arch and build-indep targets  by Bill Allombert 2001
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+# This has to be exported to make some magic below work.
+export DH_OPTIONS
+
+
+%:
+       dh $@
+
+override_dh_auto_configure:
+       dh_auto_configure -- --with-initrddir=/etc/init.d --enable-release \
+               --enable-apis=NOLEGACY --with-initscripts=sysv
+
+override_dh_auto_test:
+
+override_dh_auto_install:
+       dh_auto_install
+       contrib/make-deb-manifest util-vserver debian contrib/manifest.dat files