Add Debian package.
[util-vserver.git] / debian / Makefile-files
diff --git a/debian/Makefile-files b/debian/Makefile-files
new file mode 100644 (file)
index 0000000..aa91cd9
--- /dev/null
@@ -0,0 +1,33 @@
+## $Id$  -*- makefile -*-
+
+## Copyright (C) 2010 Daniel Hokka Zakrisson <daniel@hozac.com>
+##  
+## This program is free software; you can redistribute it and/or modify
+## it under the terms of the GNU General Public License as published by
+## the Free Software Foundation; either version 2, or (at your option)
+## any later version.
+##  
+## This program is distributed in the hope that it will be useful,
+## but WITHOUT ANY WARRANTY; without even the implied warranty of
+## MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+## GNU General Public License for more details.
+##  
+## You should have received a copy of the GNU General Public License
+## along with this program; if not, write to the Free Software
+## Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+##  
+
+
+EXTRA_DIST +=  debian/rules \
+               debian/control \
+               debian/compat \
+               debian/copyright \
+               debian/docs \
+               debian/changelog.in \
+               debian/changelog
+
+CLEANFILES +=  debian/changelog
+
+DEB_CL_DATE = $(shell date '+%a, %d %b %Y %H:%M:%S %z')
+debian/changelog: debian/changelog.in
+       $(SED) "s/@"PACKAGE_VERSION"@/$(PACKAGE_VERSION)/g;s/@"DATE"@/$(DEB_CL_DATE)/g" $< > $@